With technology advancing every day, there are new versions of software and browsers which allow your device to work with the latest apps and websites.

When you join a Call.Group call on your desktop or laptop, ensure you are accessing it from a compatible browser.

Compatible Browsers on Desktop

  • Chrome
  • Edge Chromium (previous versions of Edge will not work)
  • Firefox

You may find that Call.Group does not work as it should if you are using Safari, Internet Explorer, or an older version of Edge*. You'll need to change to one of the above browsers to make the best use of the service.

If you're using one of the compatible browsers and experiencing any functionality issues, check that you’re using the most up-to-date version of your browser. You can find out which browser version you're using here.

You'll need to download the Call.Group app if you are accessing Call.Group from your mobile or tablet. Your device's operating system will need to support the Call.Group app in order for it to work as intended. Make sure your operating system is one of the below or more recent releases.

Mobile/tablet operating systems which support the app

  • Android 7.0 (Nougat) or more recent
  • iOS 12.0 or more recent

If you're experiencing issues and you're not sure why, don't forget you can always get in touch and receive assistance from a member of the Call.Group team.

*The new version of Edge, Edge Chromium, will allow Call.Group to work.

Did this answer your question?